unreadable strings from RRDTools charts

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

unreadable strings from RRDTools charts

Alceu

Hello all,

I did a setup of Collectd in a VM with OpenBSD 6 installed to collect
data and write to RRD files (RRDTool).

Everything seems to be running OK, but all my attempts of generating
charts are resulting into something like this:

https://www.dropbox.com/s/uudpcujsgbbtrfe/salompas_spo_virtua_com_br_cpu-0_cpu-system.png?dl=0

It's a bit hard to describe (there is a data curve at right, small
because I'm running for a few minutes only), but it seems all strings
that were supposed to be there were replaced by rectangles. I tried
generating charts from all 3 Perl solutions available in the Collectd
contrib tarball and also with rrdscout (Python based), all producing the
same results.

If I would have to guess, I would say it is something with RRDTool libs
and/or graphic related libs. I tried to follow up all requirements from
RRDTool website, installed them over OpenBSD (even though the related
package didn't required them), but results remain the same.

That is happening for all resources I'm monitoring (CPU, load and memory).

I can share the RRD files if necessary, this is for a free software
project anyway (https://github.com/glasswalk3r/cpan-openbsd-smoker).

Please let me know if any of you already experimented this kind of problem.

Thanks in advance,

Alceu

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: unreadable strings from RRDTools charts

Alceu
Hello Jacques,

Thank you! I was about to give up on that!

I'm copying to the list too, hope you don't mind... maybe this will help
folks around in the future.

To get the fonts installed, one must select all the "x" sets during the
setup (not sure if they are available after installing). Basically you
uncheck the "games" set and install everything else.

After that, you will need to setup ports:

https://www.openbsd.org/faq/faq15.html#Ports

And then:

cd /usr/ports/print/freetype
make install
make clean
make clean=depends

Here is another reference (not sure why is not part of the official FAQ
anymore):

http://openbsd.das.ufsc.br/faq/truetype.html

Em 20/04/2017 06:58, Jacques Schell escreveu:

> Hi Alceu,
>
> Your RRD Graphs are not showing legends simply because fonts are missing.
> See which fonts you have by default:
> ll /usr/share/fonts/
> You must have dejavu fonts for RRDTool:
>
> root@vmn-prod:/var/www/html# ll /usr/share/fonts/dejavu/
> total 5288
> -rw-r--r--. 1 root root 611212 Feb 27  2011 DejaVuSans-BoldOblique.ttf
> -rw-r--r--. 1 root root 672300 Feb 27  2011 DejaVuSans-Bold.ttf
> -rw-r--r--. 1 root root 580168 Feb 27  2011
> DejaVuSansCondensed-BoldOblique.ttf
> -rw-r--r--. 1 root root 631992 Feb 27  2011 DejaVuSansCondensed-Bold.ttf
> -rw-r--r--. 1 root root 576004 Feb 27  2011 DejaVuSansCondensed-Oblique.ttf
> -rw-r--r--. 1 root root 643852 Feb 27  2011 DejaVuSansCondensed.ttf
> -rw-r--r--. 1 root root 345204 Feb 27  2011 DejaVuSans-ExtraLight.ttf
> -rw-r--r--. 1 root root 611556 Feb 27  2011 DejaVuSans-Oblique.ttf
> -rw-r--r--. 1 root root 720012 Feb 27  2011 DejaVuSans.ttf
> root@vmn-prod:/var/www/html#
>
> Hope this helps you.
>
> Cheers from Switzerland !
> Jacques

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Loading...