rrdtool Question. traffic after a while does not appear

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

rrdtool Question. traffic after a while does not appear

epsilon77
Hi,

Im currently working with cacti graphing traffic workstations,
whenever i add a new station took a snapshot of the traffic generated,
however after a while i consult the chart on the same date and time to
take the initial capture but traffic doesnt appear, its normal for
this to happen?

a link with screenshots [1]

Really, Thank you very much

[1]: http://forums.cacti.net/viewtopic.php?f=2&t=40270

--
Epsilon
http://wiki.debian.org/DanielEcheverry
Linux user: #477840
Debian user
Software libre
liberar blackberry
Libros online
garmin y campin

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: rrdtool Question. traffic after a while does not appear

S Shipway
> Im currently working with cacti graphing traffic workstations,
> whenever i add a new station took a snapshot of the traffic generated,
> however after a while i consult the chart on the same date and time to
> take the initial capture but traffic doesnt appear, its normal for
> this to happen?

My first thought is that you should take a look at the length of the RRAs you have defined in the RRD file.  If they are not long enough, then the historical data will be deleted due to the 'round robin' nature of the database, though at this point I would have expected the graphing utility to use a larger granularity RRA instead...  possibly you have a single RRA and it is not long enough to hold data as far back as you expect?

Steve

Steve Shipway
ITS Unix Services Design Lead
University of Auckland, New Zealand
Floor 1, 58 Symonds Street, Auckland
Phone: +64 (0)9 3737599 ext 86487
DDI: +64 (0)9 923 6487
Mobile: +64 (0)21 753 189
Email: [hidden email]
 Please consider the environment before printing this e-mail : 打印本邮件,将减少一棵树存活的机会


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RHEL6 - rrdtool dumping text

Joe Loiacono-2

It seems to be working OK ... but it keeps dumping what looks like debug text. Any known problem? Is there a switch?

Used these two RPMs:

perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm
rrdtool-1.4.7-1.el6.wrl.x86_64.rpm

Thanks,

Joe Loiacono

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

Reply | Threaded
Open this post in threaded view
|

Re: RHEL6 - rrdtool dumping text

Eric Schoeller
What does the debug text look like? What specific command are you running to trigger the text? We're running rrdtool-1.4.7 on RHEL6 over here with no strange behavior.

Eric Schoeller
University of Colorado Boulder
Office of Information Technology

On 08/10/13 14:18, Joe Loiacono wrote:

It seems to be working OK ... but it keeps dumping what looks like debug text. Any known problem? Is there a switch?

Used these two RPMs:

perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm
rrdtool-1.4.7-1.el6.wrl.x86_64.rpm

Thanks,

Joe Loiacono


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL6 - rrdtool dumping text

Joe Loiacono-2

Yes, I've had no problems with it on a previous install. But I built that one vs RPM'ing this one (however, that may be irrelevant).

flowviewerprime /var/www/cgi-bin/FlowViewer_4.2/Flow_Working 299 >/opt/rrdtool-1.4.7/bin/rrdtool update /var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool/somerville_test.rrd 1376163000:6886391
prep ds[0]     last_arg 'U'     this_arg '6886391' pdp_new 2038371736.00
proc_pdp_age 4 proc_pdp_st 1376162700  occu_pfp_age 0   occu_pdp_st 1376163000  int 296.000000  pre_int 296.000000      post_int 0.000000
PDP UPD ds[0]  elapsed_pdp_st 1 pdp_temp 6886391.00     new_prep       0.00     new_unkn_sec     0
schedule CDP_val update, RRA 2 DS 0, DNAN
Initialize CDP_val for RRA 2 DS 0: 6886391.00
schedule CDP_val update, RRA 3 DS 0, DNAN
Initialize CDP_val for RRA 3 DS 0: 6886391.00
schedule CDP_val update, RRA 6 DS 0, DNAN
Initialize CDP_val for RRA 6 DS 0: 6886391.00
schedule CDP_val update, RRA 7 DS 0, DNAN
Initialize CDP_val for RRA 7 DS 0: 6886391.00
  -- RRA Preseek 2040
  -- RRA Postseek 3864
  -- RRA WRITE VALUE 6.886391e+06, at 3864 CF:AVERAGE
  -- RRA Preseek 3872
  -- RRA Postseek 9624
  -- RRA WRITE VALUE -nan, at 9624 CF:AVERAGE
  -- RRA Preseek 9632
  -- RRA Postseek 32224
  -- RRA WRITE VALUE 6.886391e+06, at 32224 CF:MAX
  -- RRA Preseek 32232
  -- RRA Postseek 32992
  -- RRA WRITE VALUE -nan, at 32992 CF:MAX

Joe


Inactive hide details for Eric Schoeller ---08/10/2013 04:27:56 PM---What does the debug text look like? What specific command Eric Schoeller ---08/10/2013 04:27:56 PM---What does the debug text look like? What specific command are you  running to trigger the text? We'r

From: Eric Schoeller <[hidden email]>
To: [hidden email]
Date: 08/10/2013 04:27 PM
Subject: Re: [rrd-users] RHEL6 - rrdtool dumping text
Sent by: rrd-users-bounces+jloiacon=[hidden email]





What does the debug text look like? What specific command are you running to trigger the text? We're running rrdtool-1.4.7 on RHEL6 over here with no strange behavior.

Eric Schoeller
University of Colorado Boulder
Office of Information Technology

On 08/10/13 14:18, Joe Loiacono wrote:

    It seems to be working OK ... but it keeps dumping what looks like debug text. Any known problem? Is there a switch?

    Used these two RPMs:


    perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm
    rrdtool-1.4.7-1.el6.wrl.x86_64.rpm


    Thanks,

    Joe Loiacono


    _______________________________________________
    rrd-users mailing list
    [hidden email]
    https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL6 - rrdtool dumping text

oetiker
Administrator

On 10.08.2013, at 22:30, Joe Loiacono <[hidden email]> wrote:

Yes, I've had no problems with it on a previous install. But I built that one vs RPM'ing this one (however, that may be irrelevant).

flowviewerprime /var/www/cgi-bin/FlowViewer_4.2/Flow_Working 299 >/opt/rrdtool-1.4.7/bin/rrdtool update /var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool/somerville_test.rrd 1376163000:6886391
prep ds[0]     last_arg 'U'     this_arg '6886391' pdp_new 2038371736.00
proc_pdp_age 4 proc_pdp_st 1376162700  occu_pfp_age 0   occu_pdp_st 1376163000  int 296.000000  pre_int 296.000000      post_int 0.000000
PDP UPD ds[0]  elapsed_pdp_st 1 pdp_temp 6886391.00     new_prep       0.00     new_unkn_sec     0
schedule CDP_val update, RRA 2 DS 0, DNAN
Initialize CDP_val for RRA 2 DS 0: 6886391.00
schedule CDP_val update, RRA 3 DS 0, DNAN
Initialize CDP_val for RRA 3 DS 0: 6886391.00
schedule CDP_val update, RRA 6 DS 0, DNAN
Initialize CDP_val for RRA 6 DS 0: 6886391.00
schedule CDP_val update, RRA 7 DS 0, DNAN
Initialize CDP_val for RRA 7 DS 0: 6886391.00
  -- RRA Preseek 2040
  -- RRA Postseek 3864
  -- RRA WRITE VALUE 6.886391e+06, at 3864 CF:AVERAGE
  -- RRA Preseek 3872
  -- RRA Postseek 9624
  -- RRA WRITE VALUE -nan, at 9624 CF:AVERAGE
  -- RRA Preseek 9632
  -- RRA Postseek 32224
  -- RRA WRITE VALUE 6.886391e+06, at 32224 CF:MAX
  -- RRA Preseek 32232
  -- RRA Postseek 32992
  -- RRA WRITE VALUE -nan, at 32992 CF:MAX

Joe




maybe you got some debug define set while compiling

in any event, get 1.4.8 ... fewer bugs more fun

cheers tobi


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: RHEL6 - rrdtool dumping text

Joe Loiacono-2
I installed 1.4.8, but am still having debug output without asking for it.

Is there a switch somewhere where I can turn it off? I looked through the config.status file on the build and can't really see how it might have been compiled into it.

If I do a rebuild ... how can I make sure it is turned off?

Thanks!

Joe Loiacono




From:        Tobi Oetiker <[hidden email]>
To:        Joe Loiacono/USA/CSC@CSC
Cc:        "[hidden email]" <[hidden email]>, "[hidden email]" <[hidden email]>, "rrd-users-bounces+jloiacon=[hidden email]" <rrd-users-bounces+jloiacon=[hidden email]>
Date:        08/10/2013 05:22 PM
Subject:        Re: [rrd-users] RHEL6 - rrdtool dumping text





On 10.08.2013, at 22:30, Joe Loiacono <jloiacon@...> wrote:

Yes, I've had no problems with it on a previous install. But I built that one vs RPM'ing this one (however, that may be irrelevant).

flowviewerprime /var/www/cgi-bin/FlowViewer_4.2/Flow_Working 299 >/opt/rrdtool-1.4.7/bin/rrdtool update /var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool/somerville_test.rrd 1376163000:6886391
prep ds[0]     last_arg 'U'     this_arg '6886391' pdp_new 2038371736.00
proc_pdp_age 4 proc_pdp_st 1376162700  occu_pfp_age 0   occu_pdp_st 1376163000  int 296.000000  pre_int 296.000000      post_int 0.000000
PDP UPD ds[0]  elapsed_pdp_st 1 pdp_temp 6886391.00     new_prep       0.00     new_unkn_sec     0
schedule CDP_val update, RRA 2 DS 0, DNAN
Initialize CDP_val for RRA 2 DS 0: 6886391.00
schedule CDP_val update, RRA 3 DS 0, DNAN
Initialize CDP_val for RRA 3 DS 0: 6886391.00
schedule CDP_val update, RRA 6 DS 0, DNAN
Initialize CDP_val for RRA 6 DS 0: 6886391.00
schedule CDP_val update, RRA 7 DS 0, DNAN
Initialize CDP_val for RRA 7 DS 0: 6886391.00
 -- RRA Preseek 2040
 -- RRA Postseek 3864
 -- RRA WRITE VALUE 6.886391e+06, at 3864 CF:AVERAGE
 -- RRA Preseek 3872
 -- RRA Postseek 9624
 -- RRA WRITE VALUE -nan, at 9624 CF:AVERAGE
 -- RRA Preseek 9632
 -- RRA Postseek 32224
 -- RRA WRITE VALUE 6.886391e+06, at 32224 CF:MAX
 -- RRA Preseek 32232
 -- RRA Postseek 32992
 -- RRA WRITE VALUE -nan, at 32992 CF:MAX

Joe



maybe you got some debug define set while compiling

in any event, get 1.4.8 ... fewer bugs more fun

cheers tobi


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

Reply | Threaded
Open this post in threaded view
|

Re: RHEL6 - rrdtool dumping text

Joe Loiacono-2
Yay!

My shell had a setenv CFLAGS "-g -DDEBUG -I../include" line. I removed it, re-sourced the .cshrc file and still no joy ... compiled anew using root and it cleaned everything up. And the make went through a lot more steps when user=root, somehow the user 'make' may have been not re-doing every object module.

Joe




From:        Joe Loiacono/USA/CSC@CSC
To:        Tobi Oetiker <[hidden email]>
Cc:        "[hidden email]" <[hidden email]>, "rrd-users-bounces+jloiacon=[hidden email]"        <rrd-users-bounces+jloiacon=[hidden email]>
Date:        08/12/2013 11:27 AM
Subject:        Re: [rrd-users] RHEL6 - rrdtool dumping text
Sent by:        rrd-users-bounces+jloiacon=[hidden email]




I installed 1.4.8, but am still having debug output without asking for it.

Is there a switch somewhere where I can turn it off? I looked through the config.status file on the build and can't really see how it might have been compiled into it.


If I do a rebuild ... how can I make sure it is turned off?


Thanks!


Joe Loiacono




From:        
Tobi Oetiker <[hidden email]>
To:        
Joe Loiacono/USA/CSC@CSC
Cc:        
"[hidden email]" <[hidden email]>, "[hidden email]" <[hidden email]>, "rrd-users-bounces+jloiacon=[hidden email]" <rrd-users-bounces+jloiacon=[hidden email]>
Date:        
08/10/2013 05:22 PM
Subject:        
Re: [rrd-users] RHEL6 - rrdtool dumping text





On 10.08.2013, at 22:30, Joe Loiacono <
jloiacon@...> wrote:

Yes, I've had no problems with it on a previous install. But I built that one vs RPM'ing this one (however, that may be irrelevant).

flowviewerprime /var/www/cgi-bin/FlowViewer_4.2/Flow_Working 299 >/opt/rrdtool-1.4.7/bin/rrdtool update /var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool/somerville_test.rrd 1376163000:6886391
prep ds[0]     last_arg 'U'     this_arg '6886391' pdp_new 2038371736.00
proc_pdp_age 4 proc_pdp_st 1376162700  occu_pfp_age 0   occu_pdp_st 1376163000  int 296.000000  pre_int 296.000000      post_int 0.000000
PDP UPD ds[0]  elapsed_pdp_st 1 pdp_temp 6886391.00     new_prep       0.00     new_unkn_sec     0
schedule CDP_val update, RRA 2 DS 0, DNAN
Initialize CDP_val for RRA 2 DS 0: 6886391.00
schedule CDP_val update, RRA 3 DS 0, DNAN
Initialize CDP_val for RRA 3 DS 0: 6886391.00
schedule CDP_val update, RRA 6 DS 0, DNAN
Initialize CDP_val for RRA 6 DS 0: 6886391.00
schedule CDP_val update, RRA 7 DS 0, DNAN
Initialize CDP_val for RRA 7 DS 0: 6886391.00
-- RRA Preseek 2040
-- RRA Postseek 3864
-- RRA WRITE VALUE 6.886391e+06, at 3864 CF:AVERAGE
-- RRA Preseek 3872
-- RRA Postseek 9624
-- RRA WRITE VALUE -nan, at 9624 CF:AVERAGE
-- RRA Preseek 9632
-- RRA Postseek 32224
-- RRA WRITE VALUE 6.886391e+06, at 32224 CF:MAX
-- RRA Preseek 32232
-- RRA Postseek 32992
-- RRA WRITE VALUE -nan, at 32992 CF:MAX

Joe



maybe you got some debug define set while compiling

in any event, get 1.4.8 ... fewer bugs more fun

cheers tobi
_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users


_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users