lua5.0 support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

lua5.0 support

Jean-Michel Vourgère
Hi

I tried lua bindings with lua 5.3 and it looks ok. :)

However, the test at bindings/lua/test.lua.bottom is obsolete:
table.getn() doesn't exist anymore since lua 5.2. This need to be
replaced by the operator #.

I was wondering whether we should drop support for lua 5.0 altogether?
Supporting versions 5.1 - released in 2006 - and above seems good enough.

See release dates here:
http://www.lua.org/versions.html

I could work on a patch if agreed. configure.ac will be reduced.

--
Nirgal

_______________________________________________
rrd-developers mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-developers