is RRDTOOL 1.5 for Raspberry available?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

is RRDTOOL 1.5 for Raspberry available?

thom
Hi,

is there a way to get the 1.5 version of rrdtool on my Raspberry running Debian?

I installed rrdtool successfully on my Raspberry PI. But when I exported my Data via rrdxport in JSON format I figured out the the JSON Format does not have “” in it and is therefore not accepted as a valid JSON format. So I searched and found Thomas Mainkas post which covers exactly my problem and the information that this is solved in newer versions of rrdtool.  Therefore I had a look on my version of rrdtool on my Raspberry and figured out that it is 1.4.7… when I run a upgrade of rrdtool the system brings back the message that there is nothing to upgrade.
So any idea or a hint how to get the most current version for Raspberry would be helpful and highly appreciated.

Thom

Reply | Threaded
Open this post in threaded view
|

Re: is RRDTOOL 1.5 for Raspberry available?

Petteri Matilainen
Hi Thom,

Just compile it yourself. It's not that complicated. Debian is way
behind on rrdtool versions so unless someone makes the debian package
for you the fastest way is to compile it yourself. Rrdtool docs
explain the compilation process and dependencies very thoroughly:
http://oss.oetiker.ch/rrdtool/doc/rrdbuild.en.html

regards,

PM

On Tue, Jan 19, 2016 at 3:37 PM, thom <[hidden email]> wrote:

> Hi,
>
> is there a way to get the 1.5 version of rrdtool on my Raspberry running
> Debian?
>
> I installed rrdtool successfully on my Raspberry PI. But when I exported my
> Data via rrdxport in JSON format I figured out the the JSON Format does not
> have “” in it and is therefore not accepted as a valid JSON format. So I
> searched and found Thomas Mainkas post which covers exactly my problem and
> the information that this is solved in newer versions of rrdtool.  Therefore
> I had a look on my version of rrdtool on my Raspberry and figured out that
> it is 1.4.7… when I run a upgrade of rrdtool the system brings back the
> message that there is nothing to upgrade.
> So any idea or a hint how to get the most current version for Raspberry
> would be helpful and highly appreciated.
>
> Thom
>
>
>
>
>
> --
> View this message in context: http://rrd-mailinglists.937164.n2.nabble.com/is-RRDTOOL-1-5-for-Raspberry-available-tp7583252.html
> Sent from the RRDtool Users Mailinglist mailing list archive at Nabble.com.
>
> _______________________________________________
> rrd-users mailing list
> [hidden email]
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: is RRDTOOL 1.5 for Raspberry available?

thom
Hi PM,

thanks a lot for this hint!
I never compiled a project by myself... But with the description you mentioned I got it really done! A new great expierence!

Maybe you can give me a further hint. How can I integrate the program in a way that it acts as an installed program? For example that the shell command "man rrdtool" would work and also the depenencies of rrdtool are stored in the Packet manager?


Thanks again for the help!!!!
Best regards
Thom
Reply | Threaded
Open this post in threaded view
|

Re: is RRDTOOL 1.5 for Raspberry available?

Petteri Matilainen
Hi Thom,

Not sure about the man pages. I'm sure someone here can tell if man
pages are installed by default. And if you compiled and installed
rrdtool yourself you can remove the apt version so it won't interfere.
I myself use the docs on rrdtool website instead of man pages.

As for the dependencies with compiled programs there is no way to get
dependencies stored in apt with this method. But of course you can
install all the dependencies via apt if the versions are recent
enough. That's what I did.

regards,

PM

On Fri, Jan 22, 2016 at 1:27 PM, thom <[hidden email]> wrote:

> Hi PM,
>
> thanks a lot for this hint!
> I never compiled a project by myself... But with the description you
> mentioned I got it really done! A new great expierence!
>
> Maybe you can give me a further hint. How can I integrate the program in a
> way that it acts as an installed program? For example that the shell command
> "man rrdtool" would work and also the depenencies of rrdtool are stored in
> the Packet manager?
>
>
> Thanks again for the help!!!!
> Best regards
> Thom
>
>
>
> --
> View this message in context: http://rrd-mailinglists.937164.n2.nabble.com/is-RRDTOOL-1-5-for-Raspberry-available-tp7583252p7583255.html
> Sent from the RRDtool Users Mailinglist mailing list archive at Nabble.com.
>
> _______________________________________________
> rrd-users mailing list
> [hidden email]
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users