A question about --right-axis-format

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

A question about --right-axis-format

John huysing
I have several graphs were I have   "--right-axis", "1:0"  so that I have the scale on both sides of the graphs.

For most of the graphs the format of the left and right side is the same.

ie: 1Ok on the left and 10K on the right

I have a set of defaults
    my @rrdDefaults = (
        "--imgformat", "PNG", "--interlace",
        "--disable-rrdtool-tag",
        "--pango-markup",
        "--font=TITLE:20:FreeSans",
        "--font=AXIS:14:FreeSans",
        "--right-axis", "1:0",

                "--units=si",
                "--color", 'BACK#000000',      #ffffff',      # Background Color
                "--color", 'CANVAS#000000',    #ffFFFF',    # Canvas (Grid Background)
              ...
           )

But, on one graph

I have 0.1k on the left and 100.0 on the right
          1.0k                and 1000.0   on the right


Is there a way to get the same format on both side?

I have tried fiddling around with "--right-axis-format", "%3.01lf%s but that doesn't work.

John



_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users
Reply | Threaded
Open this post in threaded view
|

Re: A question about --right-axis-format

oetiker
Administrator
Hi John,

Today John huysing wrote:

> I have several graphs were I have   "--right-axis", "1:0"  so that I have
> the scale on both sides of the graphs.
>
> For most of the graphs the format of the left and right side is the same.
>
> ie: 1Ok on the left and 10K on the right
>
> I have a set of defaults
>     my @rrdDefaults = (
>         "--imgformat", "PNG", "--interlace",
>         "--disable-rrdtool-tag",
>         "--pango-markup",
>         "--font=TITLE:20:FreeSans",
>         "--font=AXIS:14:FreeSans",
>         "--right-axis", "1:0",
>                 "--units=si",
>                 "--color", 'BACK#000000',      #ffffff',      # Background
> Color
>                 "--color", 'CANVAS#000000',    #ffFFFF',    # Canvas (Grid
> Background)
>               ...
>            )


try

--right-axis 0.001:0
--right-axis-format '%lf k'

cheers
tobi

>
> But, on one graph
>
> I have 0.1k on the left and 100.0 on the right
>           1.0k                and 1000.0   on the right
>
>
> Is there a way to get the same format on both side?
>
> I have tried fiddling around with "--right-axis-format", "%3.01lf%s but
> that doesn't work.
>
> John
>

--
Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
www.oetiker.ch [hidden email] +41 62 775 9902

_______________________________________________
rrd-users mailing list
[hidden email]
https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users